Internet Explorer (IE) Browser Requirements

The new “My Apps” tabs in myRutgers requires Internet Explorer (IE) version 9 or higher. If in IE version 9 or higher the browsers default compatibility setting has been changed to a lower incompatible version, the compatibility setting will need to be changed to 9 or higher.

Change Compatibility Settings in IE:

1. First of all, please check your browser version. We need IE version 9 & higher to make My Apps work. If your browser version is lower, you need to upgrade your browser first.

ie1

2. If you do have IE9 & higher versions,  and still get a blank screen,  please click F12 Developer Tools:

ie2

3. In developer Tool window, you can click the Edge button, and select Edge, then My Apps page will be refreshed and recovered.

ie3

Related Articles